X Freaks Forum

News:

  • Welcome to X-Freaks new forum !!!
    Please read the rules :)
  • New Theme! Discussion goes here
  • X-freaks.com - online for more than 13 years!
  • latest forum news: CLICK HERE

Rose of pain covered by ChIDorI live performed

*RckChK* · 1113

0 Members and 1 Guest are viewing this topic.

Offline *RckChK*

  • Rookie
  • *
    • Posts: 19
    • View Profile
on: December 11, 2008, 12:42:16 AM
We recently had our first small live and also played Rose of pain which we kinda made different ^^.
I hope you like our version.

[youtube]http://www.youtube.com/watch?v=7eR3kibitQs&feature=channel_page[/youtube]



Offline Beauty/Broken

  • Big fan
  • ****
    • Posts: 932
    • View Profile
Reply #1 on: December 11, 2008, 01:29:35 AM
Nice to see a band covering X Japan stuff, keep at it.

P.S. - Your guitarist should really tune his guitar :p



Offline MillieQOF

  • Moderators
  • Big fan
  • *****
    • Posts: 874
    • View Profile
Reply #2 on: January 21, 2009, 10:02:07 PM
A bit like the unplugged version :) Beautiful voice, good but untuned guitar, I'd love to hear more depth and pressure in it and it'd be beautiful, but you worked very well with what you had ^^



Offline X NUT

  • Sunday Listener
  • **
    • Posts: 159
    • View Profile
Reply #3 on: January 22, 2009, 04:32:14 PM
Very nice. I enjoyed it. Do you plan on covering more X songs?



Offline *RckChK*

  • Rookie
  • *
    • Posts: 19
    • View Profile
Reply #4 on: March 15, 2009, 07:07:42 PM
Thank you ^^, yeah I'm the guitarist myself and a girl haha but I have been having problems with my tuners on the guitar, now I have replaced them that problem is gone ^^.
And we probably won´t cover more X songs since we don´t intend to be a cover band.

But we have performed again with this song, we actually wanted to play our own song, but since we had auditioned with Rose of Pain months ago we had to play it at the festival so here it is on a bigger stage with ±400 people in the audience.

P.s. It takes a while before the song starts because we intended to take a moment of silence but when I wanted to start there was no sound haha, the guitar was not plugged in correctly at the amp XD.


[youtube]http://www.youtube.com/watch?v=ts-O-Pap-bI  [/youtube]
« Last Edit: March 15, 2009, 07:09:21 PM by *RckChK* »